Problems with Nitrates

Discussion in 'Introduce Yourself' started by algy1943, Sep 30, 2012.

  1. algy1943

    algy1943

    Joined:
    Apr 1, 2010
    Messages:
    600
    Likes Received:
    17
    Location:
    Upminster essex UK
    I am suffering with high nitrates , I had a a pure white anemone , fed it and it changed to its correct colour and retained its zooxanthella , but it grew so large and moved around the tank killing all my corals with the exception of the xenias , I have since removed the anemone ,removed all the live rock , completely cleaned the tank , throughly cleaned the rock killing off all the aiptasia , new crushed rock , replaced as much of the live rock as I wanted , filled the tank ,replaced the pumps etc and let it cure for 2 weeks then replaced the fish , I have now replaced several corals by the way the tank holds 250litres , I carry out 30litres water change every 2 weeks but cannot get the nitrates below 40 , can anyone help please ?
    algy1943 :frustrat:


    __________________
    "Never argue with an idiot, they will drag you down to their level and beat you with experience"

    Current Tank Info: 250L Living reef tank, 7 fish,various corals and anemone's
     
    algy1943, Sep 30, 2012
    #1
    1. Advertisements

  2. algy1943

    wontonflip I failed Kobayashi Maru

    Joined:
    Oct 10, 2008
    Messages:
    10,446
    Likes Received:
    979
    Location:
    VA USA
    Check your new water; might have nitrates. Or your test kit could be bad (I've had a brand spanking new test kit not test properly since day 1; kept saying I had 20ppm nitrates; turned out I had 0 once I had the LFS test it and I got a new kit.)
     
    wontonflip, Sep 30, 2012
    #2
    algy1943 likes this.
    1. Advertisements

  3. algy1943

    algy1943

    Joined:
    Apr 1, 2010
    Messages:
    600
    Likes Received:
    17
    Location:
    Upminster essex UK
    Thanks wonton have tried my new salt water and shows 0 and the test kit is ok because I have an API and HAGEN both show 40 , only problem showing is the amount os algae on the glass , sand and on my lovely orange sponge which I try to clean but the sponge is very hard to brush off, Help :regular_w:regular_w:dunno::dunno:
     
    algy1943, Oct 1, 2012
    #3
  4. algy1943

    wontonflip I failed Kobayashi Maru

    Joined:
    Oct 10, 2008
    Messages:
    10,446
    Likes Received:
    979
    Location:
    VA USA
    Maybe have someone move this thread to water chemistry so more people will see it ;)
     
    wontonflip, Oct 1, 2012
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.