Mushroom coral not opening??

Discussion in 'Corals' started by SwimsWithFishes, Jan 30, 2012.

  1. SwimsWithFishes

    SwimsWithFishes

    Joined:
    Jan 26, 2012
    Messages:
    28
    Likes Received:
    0
    Location:
    Central Coast, CA
    Hey all,

    I have one mushroom coral that is not opening very well and I'm not sure why. I have a couple more that seem to be doing just fine. I have LED lighting and it is located close to the bed on a rock. It is more or less directly under the light, is this too much light for it? trying to understand what up with this one. Any help would be great. Thanks! :Cheers:
     
    SwimsWithFishes, Jan 30, 2012
    #1
    1. Advertisements

  2. SwimsWithFishes

    little_fish Moderator

    Joined:
    Mar 4, 2010
    Messages:
    15,713
    Likes Received:
    2,574
    Location:
    Denver, CO
    I would move it lower and to an area with less flow
     
    little_fish, Jan 30, 2012
    #2
    1. Advertisements

  3. SwimsWithFishes

    yvr

    Joined:
    Aug 10, 2009
    Messages:
    77
    Likes Received:
    9
    Location:
    Ft. Lauderdale, FL
    From my experience I believe that mushrooms really benefit from elevated Iodine levels in the aquariums (arround .06ppm) although some may disagree. I have found that elevated Iodine causes greater polyp extension and better colour. These observations are also noted in Reef Aquarium Vol2. If you add Iodine be sure to test for it on a regular basis.
     
    yvr, Jan 31, 2012
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.